老莫的笔记本  
  
请选择 进入手机版 | 继续访问电脑版
查看: 478|回复: 0

猜数字程序-随机数、按键、窗口创建完毕的下划线

[复制链接]

572

主题

767

帖子

3637

积分

超级版主

Rank: 8Rank: 8

积分
3637
发表于 2019-10-24 13:05:41 | 显示全部楼层 |阅读模式
这是一个很简单的猜数字比大小程序
知识点包含:局部变量、全局变量、闭包
里面有一个错误耽误我两个小时,是下划线 启动窗口前 有个下划线_ 注意这个下划线比较长。我一开始没注意  ;
源码:
  1. .版本 2

  2. .程序集 窗口程序集_启动窗口
  3. .程序集变量 那个随机数, 整数型

  4. .子程序 __启动窗口_创建完毕

  5. 信息框 (“窗口创建成功”, 0, , )
  6. 置随机数种子 (12345699)
  7. 那个随机数 = 取随机数 (0, 99)
  8. 编辑框1.内容 = “16”

  9. 输出调试文本 (那个随机数)


  10. .子程序 _编辑框1_按下某键, 逻辑型
  11. .参数 键代码, 整数型
  12. .参数 功能键状态, 整数型

  13. .判断开始 (键代码 = #回车键)
  14.     .判断开始 (到整数 (编辑框1.内容) > 那个随机数)
  15.         信息框 (“大了”, 0, “这数字太大了”, )
  16.     .默认

  17.     .判断结束
  18.     .判断开始 (到整数 (编辑框1.内容) < 那个随机数)
  19.         信息框 (“小了”, 0, “这数字太小了”, )
  20.     .默认

  21.     .判断结束
  22.     .判断开始 (到整数 (编辑框1.内容) = 那个随机数)
  23.         信息框 (“恭喜你猜对了”, 0, “劳资真帅”, )
  24.     .默认

  25.     .判断结束

  26. .默认

  27. .判断结束

复制代码


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表